Med Tech Solutions - Degraded Performance – Incident details

All systems operational

Degraded Performance

Resolved
Degraded performance
Started about 1 month agoLasted about 3 hours

Affected

MTS West US (Los Angeles)

Degraded performance from 4:11 PM to 6:12 PM, Operational from 6:12 PM to 7:01 PM

Updates
  • Resolved
    UTC
    Resolved

    The issue has been fully resolved, and all services are operating as expected. We will continue to monitor the environment to ensure sustained stability.

  • Monitoring
    UTC
    Monitoring

    Our team has implemented a corrective fix that appears to have resolved the issue. We will continue to monitor the environment to ensure ongoing stability.

  • Identified
    UTC
    Identified

    Our engineering team has successfully identified the issue, and we are actively working toward a resolution.

  • Update
    UTC
    Update

    The issue remains under active investigation by our engineering team. While we work toward resolution, some level of performance degradation may still be experienced. Further updates will be provided as additional details are confirmed.

  • Investigating
    UTC
    Investigating

    We are currently experiencing elevated CPU utilization on one of our clusters. This may result in intermittent performance degradation for some workloads.


    Our engineering team is actively investigating and taking steps to stabilize performance and mitigate any impact. We will continue to monitor the situation closely and provide updates as progress is made.

     
    Thank you for your patience, and please let us know if you notice any specific issues